Unverified Commit 9fa8589d authored by Benjamin Kampmann's avatar Benjamin Kampmann Committed by GitHub
Browse files

alpha.4 release fixes (#5303)

* Adding missing metadata for benchmark-pallet

* Missed to bump a few

* release on roling tag

* Wasm executors were missed
parent 6a38fdc0
Pipeline #2309 failed with stages
......@@ -578,7 +578,7 @@ publish-to-crates-io:
<<: *docker-env
only:
- tags
- /^v[0-9]+\.[0-9]+\.[0-9]+.*$/
- ci-release
script:
- cargo install cargo-unleash ${CARGO_UNLEASH_INSTALL_PARAMS}
- cargo unleash em-dragons --no-check ${CARGO_UNLEASH_PKG_DEF}
......
......@@ -4158,7 +4158,7 @@ dependencies = [
[[package]]
name = "pallet-example"
version = "2.0.0-alpha.3"
version = "2.0.0-alpha.4"
dependencies = [
"frame-benchmarking",
"frame-support",
......@@ -4174,7 +4174,7 @@ dependencies = [
[[package]]
name = "pallet-example-offchain-worker"
version = "2.0.0-alpha.3"
version = "2.0.0-alpha.4"
dependencies = [
"frame-support",
"frame-system",
......@@ -6101,7 +6101,7 @@ dependencies = [
[[package]]
name = "sc-executor-wasmi"
version = "0.8.0-alpha.3"
version = "0.8.0-alpha.4"
dependencies = [
"log 0.4.8",
"parity-scale-codec",
......@@ -6116,7 +6116,7 @@ dependencies = [
[[package]]
name = "sc-executor-wasmtime"
version = "0.8.0-alpha.3"
version = "0.8.0-alpha.4"
dependencies = [
"assert_matches",
"log 0.4.8",
......@@ -7544,7 +7544,7 @@ dependencies = [
[[package]]
name = "sp-wasm-interface"
version = "2.0.0-alpha.3"
version = "2.0.0-alpha.4"
dependencies = [
"impl-trait-for-tuples",
"parity-scale-codec",
......@@ -7866,7 +7866,7 @@ dependencies = [
[[package]]
name = "substrate-test-utils"
version = "2.0.0-alpha.3"
version = "2.0.0-alpha.4"
[[package]]
name = "substrate-wasm-builder"
......
......@@ -21,12 +21,12 @@ sp-panic-handler = { version = "2.0.0-alpha.4", path = "../../primitives/panic-h
wasmi = "0.6.2"
parity-wasm = "0.41.0"
lazy_static = "1.4.0"
sp-wasm-interface = { version = "2.0.0-alpha.2", path = "../../primitives/wasm-interface" }
sp-wasm-interface = { version = "2.0.0-alpha.4", path = "../../primitives/wasm-interface" }
sp-runtime-interface = { version = "2.0.0-alpha.4", path = "../../primitives/runtime-interface" }
sp-externalities = { version = "0.8.0-alpha.4", path = "../../primitives/externalities" }
sc-executor-common = { version = "0.8.0-alpha.4", path = "common" }
sc-executor-wasmi = { version = "0.8.0-alpha.2", path = "wasmi" }
sc-executor-wasmtime = { version = "0.8.0-alpha.2", path = "wasmtime", optional = true }
sc-executor-wasmi = { version = "0.8.0-alpha.4", path = "wasmi" }
sc-executor-wasmtime = { version = "0.8.0-alpha.4", path = "wasmtime", optional = true }
parking_lot = "0.10.0"
log = "0.4.8"
libsecp256k1 = "0.3.4"
......
......@@ -16,7 +16,7 @@ codec = { package = "parity-scale-codec", version = "1.2.0" }
wasmi = "0.6.2"
sp-core = { version = "2.0.0-alpha.4", path = "../../../primitives/core" }
sp-allocator = { version = "2.0.0-alpha.4", path = "../../../primitives/allocator" }
sp-wasm-interface = { version = "2.0.0-alpha.2", path = "../../../primitives/wasm-interface" }
sp-wasm-interface = { version = "2.0.0-alpha.4", path = "../../../primitives/wasm-interface" }
sp-runtime-interface = { version = "2.0.0-alpha.4", path = "../../../primitives/runtime-interface" }
sp-serializer = { version = "2.0.0-alpha.4", path = "../../../primitives/serializer" }
......
[package]
name = "sc-executor-wasmi"
version = "0.8.0-alpha.3"
version = "0.8.0-alpha.4"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
license = "GPL-3.0"
homepage = "https://substrate.dev"
repository = "https://github.com/paritytech/substrate/"
description = "This crate provides an implementation of `WasmRuntime` that is baked by wasmi."
documentation = "https://docs.rs/sc-execturo-wasmi"
documentation = "https://docs.rs/sc-executor-wasmi"
[dependencies]
log = "0.4.8"
......@@ -15,7 +15,7 @@ wasmi = "0.6.2"
parity-wasm = "0.41.0"
codec = { package = "parity-scale-codec", version = "1.2.0" }
sc-executor-common = { version = "0.8.0-alpha.4", path = "../common" }
sp-wasm-interface = { version = "2.0.0-alpha.2", path = "../../../primitives/wasm-interface" }
sp-wasm-interface = { version = "2.0.0-alpha.4", path = "../../../primitives/wasm-interface" }
sp-runtime-interface = { version = "2.0.0-alpha.4", path = "../../../primitives/runtime-interface" }
sp-core = { version = "2.0.0-alpha.4", path = "../../../primitives/core" }
sp-allocator = { version = "2.0.0-alpha.4", path = "../../../primitives/allocator" }
[package]
name = "sc-executor-wasmtime"
version = "0.8.0-alpha.3"
version = "0.8.0-alpha.4"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
license = "GPL-3.0"
......@@ -14,7 +14,7 @@ scoped-tls = "1.0"
parity-wasm = "0.41.0"
codec = { package = "parity-scale-codec", version = "1.2.0" }
sc-executor-common = { version = "0.8.0-alpha.4", path = "../common" }
sp-wasm-interface = { version = "2.0.0-alpha.2", path = "../../../primitives/wasm-interface" }
sp-wasm-interface = { version = "2.0.0-alpha.4", path = "../../../primitives/wasm-interface" }
sp-runtime-interface = { version = "2.0.0-alpha.4", path = "../../../primitives/runtime-interface" }
sp-core = { version = "2.0.0-alpha.4", path = "../../../primitives/core" }
sp-allocator = { version = "2.0.0-alpha.4", path = "../../../primitives/allocator" }
......
......@@ -4,6 +4,9 @@ version = "2.0.0-alpha.4"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
license = "GPL-3.0"
homepage = "https://substrate.dev"
repository = "https://github.com/paritytech/substrate/"
description = "Patterns to benchmark in a FRAME runtime."
[dependencies]
serde = { version = "1.0.101", optional = true }
......
......@@ -21,7 +21,7 @@ sp-io = { version = "2.0.0-alpha.4", path = "../../primitives/io" }
hex-literal = "0.2.1"
pallet-balances = { version = "2.0.0-alpha.4", path = "../balances" }
sp-core = { version = "2.0.0-alpha.4", path = "../../primitives/core" }
substrate-test-utils = { version = "2.0.0-alpha.2", path = "../../test-utils" }
substrate-test-utils = { version = "2.0.0-alpha.4", path = "../../test-utils" }
serde = { version = "1.0.101" }
[features]
......
[package]
name = "pallet-example-offchain-worker"
version = "2.0.0-alpha.3"
version = "2.0.0-alpha.4"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
license = "Unlicense"
......
[package]
name = "pallet-example"
version = "2.0.0-alpha.3"
version = "2.0.0-alpha.4"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
license = "Unlicense"
......
......@@ -30,7 +30,7 @@ sp-core = { version = "2.0.0-alpha.4", path = "../../primitives/core" }
pallet-balances = { version = "2.0.0-alpha.4", path = "../balances" }
pallet-timestamp = { version = "2.0.0-alpha.4", path = "../timestamp" }
pallet-staking-reward-curve = { version = "2.0.0-alpha.4", path = "../staking/reward-curve" }
substrate-test-utils = { version = "2.0.0-alpha.2", path = "../../test-utils" }
substrate-test-utils = { version = "2.0.0-alpha.4", path = "../../test-utils" }
frame-benchmarking = { version = "2.0.0-alpha.4", path = "../benchmarking" }
rand_chacha = { version = "0.2" }
......
......@@ -12,7 +12,7 @@ documentation = "https://docs.rs/sp-allocator"
[dependencies]
sp-std = { version = "2.0.0-alpha.4", path = "../std", default-features = false }
sp-core = { version = "2.0.0-alpha.4", path = "../core", default-features = false }
sp-wasm-interface = { version = "2.0.0-alpha.2", path = "../wasm-interface", default-features = false }
sp-wasm-interface = { version = "2.0.0-alpha.4", path = "../wasm-interface", default-features = false }
log = { version = "0.4.8", optional = true }
derive_more = { version = "0.99.2", optional = true }
......
......@@ -17,7 +17,7 @@ sp-core = { version = "2.0.0-alpha.4", default-features = false, path = "../core
sp-std = { version = "2.0.0-alpha.4", default-features = false, path = "../std" }
libsecp256k1 = { version = "0.3.4", optional = true }
sp-state-machine = { version = "0.8.0-alpha.4", optional = true, path = "../../primitives/state-machine" }
sp-wasm-interface = { version = "2.0.0-alpha.2", path = "../../primitives/wasm-interface", default-features = false }
sp-wasm-interface = { version = "2.0.0-alpha.4", path = "../../primitives/wasm-interface", default-features = false }
sp-runtime-interface = { version = "2.0.0-alpha.4", default-features = false, path = "../runtime-interface" }
sp-trie = { version = "2.0.0-alpha.4", optional = true, path = "../../primitives/trie" }
sp-externalities = { version = "0.8.0-alpha.4", optional = true, path = "../externalities" }
......
......@@ -14,7 +14,7 @@ sp-std = { version = "2.0.0-alpha.4", default-features = false, path = "../std"
sp-runtime = { version = "2.0.0-alpha.4", default-features = false, path = "../../primitives/runtime" }
[dev-dependencies]
substrate-test-utils = { version = "2.0.0-alpha.2", path = "../../test-utils" }
substrate-test-utils = { version = "2.0.0-alpha.4", path = "../../test-utils" }
sp-io ={ version = "2.0.0-alpha.4", path = "../../primitives/io" }
rand = "0.7.2"
......
......@@ -10,7 +10,7 @@ description = "Substrate runtime interface"
documentation = "https://docs.rs/sp-runtime-interface/"
[dependencies]
sp-wasm-interface = { version = "2.0.0-alpha.2", path = "../wasm-interface", default-features = false }
sp-wasm-interface = { version = "2.0.0-alpha.4", path = "../wasm-interface", default-features = false }
sp-std = { version = "2.0.0-alpha.4", default-features = false, path = "../std" }
sp-runtime-interface-proc-macro = { version = "2.0.0-alpha.4", path = "proc-macro" }
sp-externalities = { version = "0.8.0-alpha.4", optional = true, path = "../externalities" }
......
......@@ -13,7 +13,7 @@ wasmi = { version = "0.6.2", optional = true }
sp-core = { version = "2.0.0-alpha.4", default-features = false, path = "../core" }
sp-std = { version = "2.0.0-alpha.4", default-features = false, path = "../std" }
sp-io = { version = "2.0.0-alpha.4", default-features = false, path = "../io" }
sp-wasm-interface = { version = "2.0.0-alpha.2", default-features = false, path = "../wasm-interface" }
sp-wasm-interface = { version = "2.0.0-alpha.4", default-features = false, path = "../wasm-interface" }
codec = { package = "parity-scale-codec", version = "1.2.0", default-features = false }
[dev-dependencies]
......
[package]
name = "sp-wasm-interface"
version = "2.0.0-alpha.3"
version = "2.0.0-alpha.4"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
license = "GPL-3.0"
......
[package]
name = "substrate-test-utils"
version = "2.0.0-alpha.3"
version = "2.0.0-alpha.4"
authors = ["Parity Technologies <admin@parity.io>"]
edition = "2018"
license = "GPL-3.0"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment